Degraded Performance
Incident Report for Blockset
Postmortem

On August 26, 2020 at 2:53 PM PST an unusually high mempool data load was encountered which caused a short period of degraded performance for the Blockset internal database affecting some calls to the /transfer, /blockchains, /currencies and /transactions API endpoints. A small number of API calls to those endpoints were returning a 503 (Service Temporarily Unavailable) error, but would send a normal response upon retry.

To resolve the issue, we restarted the affected service which brought everything back to fully operational. We are optimizing the way we use this service and changing how our backup servers respond to avoid future issues.

No data corruption, loss of data, or data inaccuracies occurred during or after this incident. No other services were effected.

Posted Aug 28, 2020 - 19:35 UTC

Resolved
This incident has been resolved.
Posted Aug 26, 2020 - 19:30 UTC