Degraded Performance
Incident Report for Blockset
Postmortem

On October 7, 2020 at 4:26 AM PST to 7:30 AM PST Blockset experienced degraded performance with the /blockchains and /currencies APIs due to a higher load during Bitcoin testnet reimporting for data optimization.

To resolve the issue, the affected services were restarted which brought everything back to fully operational. No further delays are expected. Future reimporting of data will be reschedule in order to build a more robust test suite to ensure no performance degradation occurs in the future. Additional monitoring and alerting is being added to many Blockset services in order to reduce response and resolution time for future issues.

No data corruption, loss of data, or data inaccuracies occurred during or after this incident. No other services were effected.

Posted Oct 13, 2020 - 17:25 UTC

Resolved
On October 7, 2020 at 4:26 AM PST to 7:30 AM PST Blockset API endpoints experienced increased degraded performance due to a higher system load during Bitcoin testnet reimporting for data optimization.
Posted Oct 07, 2020 - 16:00 UTC