Degraded Performance
Incident Report for Blockset
Postmortem

On August 17, 2020 at 3:17 AM PST an abnormally large block on bitcoin-testnet caused a short period of degraded performance for the Blockset internal database affecting some calls to the /transfer API endpoint.  A small number of API calls to that endpoint were returning a 504 (Gateway Time-out) error, but would send a normal response upon retry.

To resolve the issue, the abnormal block was temporarily skipped and then immediately reimported.  Database schema changes to better handle this type of large abnormal block are being implemented to prevent this issue going forward.

No data corruption, loss of data, or data inaccuracies occurred during or after this incident.  No other services were effected.

Posted Aug 21, 2020 - 01:34 UTC

Resolved
This incident has been resolved.
Posted Aug 17, 2020 - 08:00 UTC