Degraded Performance
Incident Report for Blockset
Postmortem

On Mar 21, 2021 at 3:15 PM PST to Mar 22, 2021 at 12:00 PM PST Blockset fell behind from tip for the Ethereum mainnet and Ethereum Ropsten chains only due to a regression issue in our last maintenance release. The maintenance release caused Blockset to error if there were no transactions in a block which slowed down the processing of subsequent blocks.

To resolve the issue, the Blockset engineering team added the appropriate handling for empty blocks. Shortly after the affected chains were processing at tip again.

No data corruption, loss of data, or data inaccuracies occurred during or after this incident. No other services or chains were were affected.

Posted Mar 30, 2021 - 23:32 UTC

Resolved
This incident has been resolved.
Posted Mar 21, 2021 - 20:00 UTC